Salad on linux says that my GPU is uncompatible in Linux

So, recently I installed Linux (POP OS) in my PC that has A RX 580 GPU. But when I open miner details it says that my GPU uncompatible if i use the override GPU compatiblity my PC still can’t mine anything. I have installed all the required drivers and apps for gaming but Salad mining process still doesn’t work. If there is a way to fix this I will be very thankful.


Same, I’m on Arch Linux and having the exact same issue.

EDIT: I do have the correct drivers and they are installed correctly.